AWS Outage
Incident Report for Asana
Postmortem

Incident: The Amazon Web Services availability zone where most of our customers are hosted experienced network connectivity issues. (AWS postmortem)

Impact: Background actions and webhooks were delayed as a result of this incident. In addition, two of the databases we use to store customer data became unavailable during these issues. Users with data in the affected databases were unable to use Asana.

Moving forward: As a result of this incident, Asana is exploring diversifying its fallback tooling.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Dec 10, 2021 - 19:33 UTC

Resolved
We have mostly recovered and our API and Event Distribution should be catching up soon.
Posted Dec 07, 2021 - 18:46 UTC
Update
We are seeing early signs of recovery.
Posted Dec 07, 2021 - 17:50 UTC
Update
We are continuing to investigate this issue. Multiple AWS services are impacted and they are actively working to mitigate this issue. We do not have an ETA for resolution.
Posted Dec 07, 2021 - 17:16 UTC
Update
We are working with our AWS technical account manager to understand the impact of this outage.
Posted Dec 07, 2021 - 16:39 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:23 UTC
Investigating
AWS is experiencing infrastructure issues in the US. We are actively working on the issue.
Posted Dec 07, 2021 - 16:09 UTC
This incident affected: US (App, API, Mobile, Automations and Background Actions, Webhooks and Event Streams).