Major Outage
Incident Report for Asana
Postmortem

Incident: Asana pushed a code change that caused a misconfiguration in our database connection pools. During a push, we reached limits in our connection pools that caused saturation of our databases, preventing requests from being completed.

Impact: Asana was inaccessible to users in all regions for 29 minutes. Many users experienced delays in loading the app for an additional 7 minutes. No customer data was lost.

Moving forward: After fixing the original misconfiguration, we are reviewing and updating other database connection limits. We will be improving dashboards and monitoring to reduce time to resolution for database connection issues.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Feb 17, 2022 - 00:30 UTC

Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 21:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 09, 2022 - 21:11 UTC
Identified
Our team has identified the problem and is currently working on a fix. We appreciate your patience and apologize for the inconvenience!
Posted Feb 09, 2022 - 21:10 UTC
Investigating
We're currently experiencing some difficulties; as a result, a majority of our users are unable to access Asana. Our Development Team is currently working to resolve this issue as soon as possible. Sincere apologies for the inconvenience caused, please keep an eye on this page for the latest updates.
Posted Feb 09, 2022 - 20:52 UTC
This incident affected: App, API, Mobile, Automations and Background Actions, and Webhooks and Event Streams.