Partial Outage - EUDC
Incident Report for Asana
Postmortem

Incident: A server version change resulted in some servers in the European and Australian data centers becoming incapable of serving new sessions, leading to users being unable to load Asana.

Impact: From 3:19 UTC to 8:36 UTC, a significant portion of attempts to start new sessions failed for customers with data residency in Europe or Australia. ~20% of requests failed in Europe and ~80% failed in Australia. Existing sessions were unaffected, and there was no loss of customer data.

Moving forward: We have added monitoring to alert us of this failure case, and have also added safeguards to the deployment process to prevent servers from reaching this state again.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Aug 09, 2022 - 20:00 UTC

Resolved
Our engineers have fixed the issue and Asana is now running normally. Again sincere apologies for any inconvenience this caused!
Posted Jul 28, 2022 - 08:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2022 - 08:23 UTC
Investigating
We are currently experiencing some difficulties; as a result, some customers who are hosted in our EU Data Center may be experiencing issues accessing Asana. We are currently investigating this issue and hope to have it fixed as soon as possible. Our sincere apologies for the inconvenience; if you’re impacted by this, please keep an eye on this page for the latest updates.
Posted Jul 28, 2022 - 07:36 UTC
This incident affected: US (App).