Trouble with email
Incident Report for Asana
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 23:32 UTC
Investigating
We identified issues with email integrations (both incoming and outgoing). Our team is working on the case and we'll report back once we have an update to share.
Posted Feb 28, 2020 - 23:05 UTC
This incident affected: US (App).