Major Outage
Incident Report for Asana
Postmortem

What happened

  • At 2021-10-14 22:03 UTC a configuration change we made triggered a bug, causing all of one kind of stateful servers to crash
  • Once identified we reverted the change, but because the servers were stateful, it took time for them to start and warm their caches before they could serve normally

What we'll do moving forward

  • We'll be doing additional review and improving our testing processes as changes like these are rolled out

Est down time:

  • 15 minutes, plus 10 minutes of partial downtime during recovery
Posted Oct 27, 2021 - 22:41 UTC

Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 22:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 14, 2021 - 22:27 UTC
Investigating
We're currently experiencing some difficulties; as a result, a majority of our users are unable to access Asana. Our Development Team is currently working to resolve this issue as soon as possible. Sincere apologies for the inconvenience caused, please keep an eye on this page for the latest updates.
Posted Oct 14, 2021 - 22:10 UTC
This incident affected: App, API, Mobile, Automations and Background Actions, and Webhooks and Event Streams.