App and API downtime

Incident Report for Asana

Postmortem

Incident: A configuration change triggered a bug affecting how internal systems process configuration data, leading to application downtime. The issue impacted internal server uptime, resulting in approximately 28 minutes of degraded service on March 25, 2025, from 22:32 UTC to 23:00 UTC (3:32 PM to 4:00 PM PDT).

Impact: During the incident, customers experienced difficulties accessing Asana on web and mobile apps, including login failures and errors while using the application. Internal services gradually recovered after the problematic change was reverted.

Moving forward: We are enhancing our configuration validation processes to prevent similar issues. Additional monitoring and safeguards are being introduced to ensure rapid identification and recovery from similar incidents.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Mar 27, 2025 - 19:38 UTC

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 23:09 UTC

Update

Our systems have recovered, and we are continuing to monitor.
Posted Mar 25, 2025 - 23:05 UTC

Monitoring

Asana App and API had about 9 minutes of downtime due to a configuration error; a fix has been implemented, and we are observing for recovery.
Posted Mar 25, 2025 - 22:47 UTC
This incident affected: US (App, API), EU (App, API), Japan (App, API), and Australia (App, API).