Degraded performance
Incident Report for Asana
Postmortem

Incident: Beginning around 7am UTC, we began observing API traffic failures, which continued to deteriorate. When action was taken to resolve the issues at a high peak traffic time, key components of the system overloaded.

Impact: Asana experienced approximately 50% unavailability from 14:10-14:36 UTC and approximately 30% unavailability from 16:21-16:30 UTC. An operator error during the final part of the response caused full unavailability from 18:58-19:40 UTC. The API remained unavailable until 19:54 UTC. Background systems resumed normal operation by 20:15 UTC.

Moving Forward: We have since updated our tools to make operator error unlikely to recur, and are investigating the cause of the initial problems.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Apr 13, 2022 - 00:40 UTC

Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 20:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2022 - 19:52 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2022 - 19:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2022 - 19:14 UTC
Monitoring
Our team is currently monitoring the issue. We appreciate your patience in the meantime!
Posted Apr 04, 2022 - 16:14 UTC
Identified
The issue has been identified and a fix is being implemented. More customers may now be able to access Asana, but some customers may still have issues updating or loading certain objects.
Posted Apr 04, 2022 - 14:58 UTC
Investigating
We are currently experiencing some difficulties; as a result, Asana may not be available for some customers. Our development team is currently investigating this issue and we're hoping to get it fixed as soon as possible. Sincere apologies for the inconvenience; if you're impacted by this issue, please keep an eye on this page for the latest updates.
Posted Apr 04, 2022 - 14:33 UTC
This incident affected: US (App, API, Mobile).