Degraded Performance
Incident Report for Asana
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 16:55 UTC
Investigating
We are currently experiencing some difficulties; as a result, some customers may be seeing a degraded performance. Our Development Team is currently investigating this issue and we're hoping to get it fixed as soon as possible. Sincere apologies for the inconvenience; if you're impacted by this issue, please keep an eye on this page for the latest updates.
Posted Jul 12, 2021 - 13:31 UTC
This incident affected: US (App).