Loading Issues
Incident Report for Asana
Resolved
This incident has been resolved.
Posted Aug 14, 2019 - 18:35 UTC
Monitoring
We have fixed the issue and are monitoring results.
Posted Aug 14, 2019 - 18:33 UTC
Identified
Some users are having trouble loading some pages in Asana. We apologize for the disruption and are fixing the issue!
Posted Aug 14, 2019 - 18:19 UTC
This incident affected: US (App).